Jump to content

Cuarto que mate, problema al configurar las entidades (SOLUCIONADO)


FREDDY

Recommended Posts


  • Followers:  0
  • Content Count:  539
  • Reputation:   660
  • Joined:  12/06/2014
  • Status:  Offline

Hola, de nuevo yo ^^

Bueno lo estoy intentando hacer es un cuarto que cuando entras y tocas un botón se cierre una puerta y luego de X seg te mate, yo lo que hice fue crear el cuarto poner el botón y un multi_manager que active el aaatriger (trigger_hurt) y la puerta, pero lo que pasa es que cuando toco el botón me mata al instante y después se cierra la puerta, lo que yo quiero es que cuando toques el botón PRIMERO se cierra la puerta y después de X segundos te mate. Estoy medio desconcertado en eso.

 

150210123732715823.png

8L4LlV.png
Link to comment
Share on other sites


  • Followers:  3
  • Content Count:  573
  • Reputation:   729
  • Joined:  06/23/2014
  • Status:  Offline

Que es "muerto1hurt#!"?

 

Viendolo asi, estaria correcto en que se cierre la puerta y despues te mate pero el otro hurt#1 no se que le asignaste..


Lopago-2.png
Link to comment
Share on other sites


  • Followers:  0
  • Content Count:  539
  • Reputation:   660
  • Joined:  12/06/2014
  • Status:  Offline

Bue al final era un error mio de cálculo, jajaja que pelo... soy jajaja (eso pasa cuando estás sin comer y sin dormir haciendo el mapa jajaja)

8L4LlV.png
Link to comment
Share on other sites


  • Followers:  0
  • Content Count:  112
  • Reputation:   426
  • Joined:  06/30/2014
  • Status:  Offline

El problema es este: lo que vos hiciste seguramente es, agregaste la puerta en el multimanager para que se active a los 0,1 segundos; despues el hurt para que se active a los 3 segundos y el hurt de nuevo a los 0,1 segunos para que se desactive instantaneamente. Lo que no tuviste en cuenta, es que el multimanager no sigue un orden para ejecutar los eventos que le agregaste, se ejecutan en el tiempo especificado; asi, el trigger y la puerta se activan al mismo tiempo (fijate que ambos estan en 0,1 segundos), luego el trigger se desactiva a los 3 segundos.

 

para que funcione como vos queres tenes que cambiar el tiempo del trigger hurt de 0,1 a 3,1.

 

Modifica eso y vas a ver como se arregla.

 

Saludos

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
×
×
  • Create New...